XS11.com Forums

XS11.com Forums (http://www.xs11.com/forum/index.php)
-   XS11/XJ11 Discussion (http://www.xs11.com/forum/forumdisplay.php?f=2)
-   -   Front caliper pistons sticking after rebuild (http://www.xs11.com/forum/showthread.php?t=39886)

BigOates 05-28-2013 04:49 PM

Front caliper pistons sticking after rebuild
 
I had two front calipers that were frozen. I pumped them out with a grease gun, cleaned up the pistons and inside the calipers (no pitting on the pistons and minimal pitting on the calipers. Problem I'm having now is I cannot get the piston to go back in without sticking. The problem seems to be either the seal or the seal groove. Without the seals in the pistons slide in easily. I've tried both the old and new seals in the calipers and can't get the piston past about halfway into the caliper. Anyone have any ideas?

bikerphil 05-28-2013 05:36 PM

There may still be crud/corrosion in the caliper groove not letting the seal fit in properly causing it to bind the piston. Did you clean that groove with a dremel wire wheel? Did you lube the seal/piston with clean brake fluid? Is the piston going in perfectly straight?

BigOates 05-28-2013 07:54 PM

Yeah I cleaned it with a wire wheel. I went back out there at your suggestion and decided to take the pick set and a precision flat head to the groove one last time. You were definitely right. Apparently I missed just enough in the corners of the grooves to make a difference. Cleaned them both and used a liberal amount of brake cleaner and they went right in.

bikerphil 05-28-2013 09:45 PM

Good deal, glad you got it sorted out so quickly.


All times are GMT -6. The time now is 06:52 AM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.

Integrated by BBpixel ©2004-2022, jvbPlugin