Home arrow Forums



Go Back   XS11.com Forums > Idle Talk Forum > XS11/XJ11 Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 01-18-2016, 03:45 AM
russell russell is offline
XSive
 
Join Date: Aug 2002
Location: sydney australia
Posts: 44
Oil Pressure Switch

Hi,

Read a post on how to check the oil pressure sensor as the oil light does not come on. Unplugged the wires, turned key on, grounded each wire, nothing. Removed the sensor and sprayed carb cleaner in the sensor. Question? how easy should the plunger move, i'm finding i have to stick a screw driver in and tap it to move the plunger. I'm thinking the plunger should move freely!!!

Connected it all up and still the oil light does not come on. Where to from here????
Reply With Quote
  #2  
Old 01-18-2016, 06:39 AM
natemoen's Avatar
natemoen natemoen is offline
Master of XSology
 
Join Date: May 2010
Location: Fargo
Posts: 8,624
Did you check to see if the light bulb is burnt out?
__________________
Nathan
KD9ARL

μολὼν λαβέ

1978 XS1100E
K&N Filter
#45 pilot Jet, #137.5 Main Jet
OEM Exhaust
ATK Fork Brace
LED Dash lights
Ammeter, Oil Pressure, Oil Temp, and Volt Meters

Green Monster Coils
SS Brake Lines
Vision 550 Auto Tensioner

In any moment of decision the best thing you can do is the right thing, the next best thing is the wrong thing, and the worst thing you can do is nothing.

Theodore Roosevelt
Reply With Quote
  #3  
Old 01-18-2016, 07:03 AM
TopCatGr58's Avatar
TopCatGr58 TopCatGr58 is offline
Administrator
 
Join Date: Jul 2002
Location: Portsmouth, Va.
Posts: 12,621
Yes, the switch does have a weak spring in it so you will feel a little resistance. Like Nate said you want to make sure the bulb works. It should light up when you turn the key on before starting, and then go out once running. If not on with just key on, then bulb probably burnt out.
Reply With Quote
  #4  
Old 01-19-2016, 03:40 AM
motoman motoman is offline
Master of XSology
 
Join Date: Aug 2005
Location: Grand Junction, Colorado
Posts: 8,309
Might also, if bulb works, remove the pressure switch and blow it clean with Brake-Kleen and re-install.
__________________
81H Venturer1100 "The Bentley" (on steroids) 97 Yamaha YZ250(age reducer) 92 Honda ST1100 "Twisty"(touring rocket) Age is relative to the number of seconds counted 'airing' out an 85ft. table-top.
Reply With Quote
  #5  
Old 02-21-2016, 03:30 AM
russell russell is offline
XSive
 
Join Date: Aug 2002
Location: sydney australia
Posts: 44
Checked the connection with a circuit tester. Has power from the light panel. Changed the bulb over from one that was working. Checked the circuit all the way down to the oil pressure switch switch, power all the way through, yet the light still doesn't come on. What am I missing here?
Reply With Quote
  #6  
Old 02-21-2016, 04:55 AM
mack mack is offline
XS-XJ Guru
 
Join Date: Sep 2009
Location: Ontario, Canada
Posts: 2,411
Light

The light won't come on in a running motor if it's working correctly. I remember Crazy steve explaining this several months ago. When no pressure is there, contact is maintained and the light stay's on. When the oil is flowing through the system, it forces the switch open, breaking contact and the light goes off. Thats why at start up the light only flickers on for a second, then goes out.
__________________
mack
79 XS 1100 SF Special
HERMES
original owner
http://i946.photobucket.com/albums/a...ps6932d5df.jpg

81 XS 1100 LH MNS
SPICA
http://i946.photobucket.com/albums/ad305/mack-055/2.jpg

78 XS 11E
IOTA
https://youtu.be/wB5Jfbp6SUc
https://youtu.be/RaI3WYHSuWA



Have recovery trailer and shop if you breakdown in my area.
Frankford, Ont, Canada
613-398-6186

Last edited by mack; 02-21-2016 at 04:57 AM.
Reply With Quote
  #7  
Old 02-21-2016, 03:28 PM
crazy steve crazy steve is offline
XS-XJ Guru MODERATOR
 
Join Date: Jan 2009
Location: Beautiful outer Yelm, WA
Posts: 7,932
All the pressure sensor does is supply the ground for the indicator light; if grounding the wire to the sensor doesn't light a known good bulb, the problem is in the wiring, not the sensor. If you do have 12V power coming to the sensor and a good lamp doesn't light when grounding the wire, then the problem is either a misconnection somewhere or a shorted out lamp socket. At the socket, power should come into it on the center pin for the lamp and go out to the sensor on the socket outer shell. With a lamp installed, you should read about 20 ohms between the input wire and the outer shell (the resistance of the lamp when cold).

Now after correcting that, you may still have a bad pressure switch. If it's been sending 12V to the switch and the light isn't coming on, that's basically a dead short and it may have damaged the contacts in the switch. To check that, check for continuity between the sensor body and it's wire connection. At rest (with the motor not running), you should have continuity between these. With the motor running, this should go 'open' (no continuity). Make sure you have continuity between the sensor body and the battery ground also; if the sensor has been installed with any sort of thread sealer, that can interfere with the electrical connection between the sensor and the engine cases.
__________________
Fast, Cheap, Reliable... Pick any two

'78E original owner - resto project
'78E ???? owner - Modder project FJ forks, 4-piston calipers F/R, 160/80-16 rear tire
'82 XJ rebuild project
'80SG restified, red SOLD
'79F parts...
'81H more parts...

Other current bikes:
'93 XL1200 Anniversary Sportster 85RWHP
'86 XL883/1200 Chopper
'82 XL1000 w/1450cc Buell, Baker 6-speed, in-progress project
Cage: '13 Mustang GT/CS with a few 'custom' touches
Yep, can't leave nuthin' alone...

Last edited by crazy steve; 02-21-2016 at 04:59 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -6. The time now is 04:18 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Integrated by BBpixel ©2004-2022, jvbPlugin